support.fideliscare.org
Incident Report for Surfly
Resolved
Clear event for support.fideliscare.org; HTTPS - Start A Session (support.fideliscare.org): Failure at step 6: Unable to find element with name 'url'
Posted May 04, 2020 - 10:54 CEST
Identified
Outage event for support.fideliscare.org; HTTPS - Start A Session (support.fideliscare.org): Failure at step 6: Unable to find element with name 'url
Posted May 04, 2020 - 10:46 CEST
This incident affected: General Service Availability.