surfly.us
Incident Report for Surfly
Resolved
Clear event for surfly.us; HTTPS (surfly.us): : Failed to establish a new connection: Connection refused
Posted May 06, 2020 - 12:24 CEST
Identified
Outage event for surfly.us; HTTPS (surfly.us): : Failed to establish a new connection: Connection refused
Posted May 06, 2020 - 12:22 CEST
This incident affected: General Service Availability.