Surfly Application (surfly.com)
Incident Report for Surfly
Resolved
Clear event for Surfly Application (surfly.com); HTTPS (surfly.com): : Failed to establish a new connection: Connection refused
Posted Sep 14, 2020 - 18:42 CEST
Identified
Outage event for Surfly Application (surfly.com); HTTPS (surfly.com): : Failed to establish a new connection: Connection refused
Posted Sep 14, 2020 - 18:41 CEST
This incident affected: General Service Availability.