surfly-us.com
Incident Report for Surfly
Resolved
Clear event for surfly-us.com; HTTPS (surfly-us.com): : Failed to establish a new connection: Connection refused
Posted Sep 16, 2020 - 18:33 CEST
Identified
Outage event for surfly-us.com; HTTPS (surfly-us.com): : Failed to establish a new connection: Connection refused
Posted Sep 16, 2020 - 18:32 CEST
This incident affected: General Service Availability.