Surfly Service Status status page
Incidents

Singapore Infrastructure Down

resolvedMAJORaffectedSurfly Singaporelasted 1h 13min 59s

The incident has been resolved

resolved
Jun 2 10:40:17 (UTC)

Health check failed for prod-cobro-assg-1

investigating
Jun 2 09:26:18 (UTC)
Powered by Checkly