Surfly Service Status status page
Incidents

US West Infrastructure Down

MAJORaffectedSurfly US Westlasted13min 56s

The incident has been resolved

resolved
Apr 8 11:48:55 (UTC)

Health check failed for prod-cobro-nwsf-1

investigating
Apr 8 11:34:59 (UTC)
Powered by Checkly